Installationsprobleme gnumed 0.2.8 / ubuntu 7.10

Moderatoren: shilbert, Forum Moderatoren

Installationsprobleme gnumed 0.2.8 / ubuntu 7.10

Beitragvon olivers » Freitag 4. Januar 2008, 13:53

Hallo,

system: ubuntu 7.10

Installation:
mit dem angebenen installationsskript server installiert
mit ubuntu software installation gnumed client hinzugefügt

skripte so gut wie dokumentiert angepasst
gnumed.conf (localhost)

beim start von gnumed gibte folgende fehlermeldung:

log file is [/home/ostrixner/.gnumed/gnumed.log]
,========================================================
| Unhandled exception caught !
| Type : <type 'exceptions.AttributeError'>
| Value: 'module' object has no attribute 'SQL_IN'
`========================================================
Traceback (most recent call last):
File "/var/lib/python-support/python2.5/Gnumed/wxpython/gnumed.py", line 265, in <module>
setup_cfg_files()
File "/var/lib/python-support/python2.5/Gnumed/wxpython/gnumed.py", line 167, in setup_cfg_files
from Gnumed.pycommon import gmCfg, gmNull
File "/var/lib/python-support/python2.5/Gnumed/pycommon/gmCfg.py", line 63, in <module>
import gmLog, gmNull, gmPG2, gmTools
File "/var/lib/python-support/python2.5/Gnumed/pycommon/gmPG2.py", line 802, in <module>
psycopg2.extensions.register_adapter(tuple, psycopg2.extras.SQL_IN)
AttributeError: 'module' object has no attribute 'SQL_IN'

kann mir bitte jemand weiterhelfen, damit ich gnumed zum laufen bekomme?
olivers
 
Beiträge: 3
Registriert: Freitag 4. Januar 2008, 13:34

mehr infos

Beitragvon olivers » Dienstag 8. Januar 2008, 17:50

ok, selbst ist der Mann :-)

habe folgenden Link beigefügt

https://bugs.launchpad.net/ubuntu/+sour ... bug/154136

, allerdings noch nicht entsprechendes ausprobiert.

Sobald ich dazu komme und weitere Infos habe poste ich sie.

Falls allerdings jemand doch eine passende Lösung hat, freu ich mich natürlich riesig.
olivers
 
Beiträge: 3
Registriert: Freitag 4. Januar 2008, 13:34

to be continueed ..

Beitragvon olivers » Mittwoch 9. Januar 2008, 12:44

ok, die Lösung für den Bug war nicht nützlich

habe dann einige python pakete nachinstalliert (leider nicht mehr alle gemerkt, aber vielleicht gibt es bald eine Doku welche Pakete ebnötigt werden?)

gnumed deinstalliert

gnumed installiert (apt-get install gnumed-client)

gnumed gestartet

warnmeldung und voila ein Anmeldefenster

so nun muss ich die Datenbank von _v8 wieder auf _v6 bringen

das skript net-install lässt sich erneut starten, datenbank update auf v6 hat funktioniert,

gnumed startet, zwar mit wanrmeldungen, aber es läuft erstmal.

benutzer any-doc eingeloggt, beim patienten anlegen kommen die ersten fehlermeldungen.

GIbt es ein ubuntu-update auf die neuesten versionen, bzw. eine anleitung wie man die aktuellsten sourcen selbst downloaden und installieren kann?



unter Ubuntu lässt sich nur die version 2.6.3 installieren, die benötigt die datenbank version _v6. Also bei der Benutzung des net-install skriptes darauf achten dass das update von v2 nur bis v6 läuft.
olivers
 
Beiträge: 3
Registriert: Freitag 4. Januar 2008, 13:34

aktuelle Version unter Ubuntu

Beitragvon shilbert » Sonntag 13. Januar 2008, 18:30

Hallo,

Also offiziell gibt es keine Möglichkeit. Ubuntu macht keine updates. Sinvoll ist absolut 0.2.8.1 bzw. 0.2.8.3 zu nehmen und datenbank v8.

Erste Möglichkeit sind die Pakete von Debian. Die sind bei 0.2.8.1. Zwei Möglichkeit ist direkt aus den sourcen.

Das ist sogar sehr einfach. Einfach nur das GNUmed-client tgz von www.gnumed.de/downloads/ runterladen , entpacken und direkt aus dem verzeichnis starten.

Bei Fragen hier melden und wiki.gnumed.de lesen.

Hat man es einmal auf der Platte ist es ganz einfach zu ner neuen version zu kommen.
shilbert
 
Beiträge: 132
Registriert: Mittwoch 23. August 2006, 21:48

GNUmed in Ubuntu

Beitragvon shilbert » Sonntag 17. Februar 2008, 15:34

Aktuelle Pakete für Ubuntu sind nun verfügbar.

Siehe wiki.gnumed.de unter dem Abschnitt für Ubuntu
shilbert
 
Beiträge: 132
Registriert: Mittwoch 23. August 2006, 21:48


Zurück zu GNUmed

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

    rechtliche Hinweise - Disclaimer

    Impressum:

    EWERK Medical Care GmbH
    Postadresse: Markt 16, 04109 Leipzig

    Telefon: 0341 4264977
    Fax: 0341 4264978
    Web: www.ewerk.com
    E-Mail: forum@med-support.de

    Geschäftsführer: Frank Richter, Ingo Günther
    Amtsgericht Leipzig HRB 20896